Short guide to measuring reverberation and time using WinMLS2000

This is a guide to get you started performing reverberation time measurements. 

Some issues are not yet added, those are marked in red.

Introduction

WinMLS2000 is software for measuring audio, acoustics and vibrations. By loading the right setup, WinMLS becomes a user friendly system for measuring reverberation time as shown in the figure below.
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Preparation

Before we can start measuring we must load or set the correct settings. When you have done this once, you will not need to do this the next time you perform or analyze a measurement. When the software is opened the next time, it remembers the previous settings.

Preparation for performing a measurement

How to set up your hardware is described in the document ‘GetStartedWithWinMLS.doc’. If you are going to perform WinMLS to perform the measurements, please read document  before continuing. If not, you may skip the rest of this section and continue on next.

To perform a simple 1-channel measurement, connect a microphone to the left input of the sound card and a loudspeaker to the left output as shown below


[image: image2.wmf] 

Loadspeaker 

 

as Output

 

Sound Card

 

Left    Right

 

   

Input

 

Right   Left

 

 

Output

 

Playback 

signal

 

Microphone 

 

as Input

 

Recorded signal

 


Loading the correct setup

After starting and registering WinMLS you will first see the dialog box
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If you click continue, you will see the dialog box shown below.
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Select the setup called ‘RoomAcoustics’ in the list in the dialog box, like shown in the figure and read the Setup description. 

Results

You can open a measurement file (e.g. *.wav or Norsonic *.sdf) from File->Open.... For the room acoustics parameter(s) to be calculated, the file must contain an impulse response and not for example background noise.

After the measurement is opened or performed in WinMLS, it will be displayed and look something like shown below.
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(The current setup displays only one plot as default, is this better?)

Two plots are displayed, the lower displays the measured impulse response plotted on a logarithmic y-axis. If you do not want to display this lower plot, then click the [image: image6.bmp] button on the Plot Toolbar found in the middle bottom of the screen in the figure above.

The upper plot displays the reverberation time in third-octaves. Please note that the yellow number marks [image: image7.png]


 on each octave-band point is set to inform about the quality. The number displays the effective decay range and should be greater than 25 to give a reliable result. To turn off these marks, make sure [image: image8.png]¥ Display mark above each data point



 is not checked in the dialog box shown below.
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To open this dialog box, use Plot->Plot Type Settings->Room Acoustics... or the F5 key or click the [image: image10.bmp] button on the Plot Toolbar.

Set the marks to display the reverb time instead of the EDR as shown in the figure below by uncecking [image: image11.png][ Setmark to EDR (effective decay range]



.
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Plotting, how does it work?

For an introduction to the plotting, see the document “GetStartedWithWinMLS”. The two figures found at the bottom of this document are very useful and should be printed out.

Displaying other room acoustical parameters

From the plot type settings (Plot->Plot Type Settings->Room Acoustics...) you can select what parameter you want to plot as shown below
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How to calculate statistics, such as average and max/min on plotted curves?

Computing average and other statistics can be done by exporting the data, but it can also be done directly in the plot.

First plot the curves you want to compute the mean value from. An example is shown below
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Now use Plot->Add Curve(s)... to open the dialog shown below
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Mark the curves you want to include for computing the mean value and click [image: image16.png]Add curve




 to add the curve and exit the dialog. The new curve is named Mean and is shown in the figure below
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Auto-statistics

Statistics, such as mean value, can also be set to updated automatically. It updates whenever there is a change in the curves in the plot, e.g. when a new curve is added. Note that the statistics is computed on the visible curves (the curves that are checked in the legend in the figure below, 1032ACentre is not checked and therefore not visible in the plot).

In other words, in the figure below, the blue curve is set to invisible (unchecked), therefore the auto-statistics is computed from the black and the red curve.
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Turn on auto-statistics from Plot->Overlay settings.... Make sure the settings are set as shown below.
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Click the [image: image20.bmp] button to display the colors and linestyles for the Mean curve as shown below
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Save/Export Data in plot

By doing several measurements, the curves will be plotted on top of each other if [image: image22.png]+ Overlay On



  is checked on the Plot menu, or if the button in the figure below is turned on.
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An example of three measurements plotted on top of each other in WinMLS and exported using Edit->Copy Plot is shown below (the EDR numbers are not displayed as marks here).
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These data can be saved to a text-file using File->Export Data... (shortcut Ctrl+E). An example of the data for two curves is shown below. The x-axis is the frequency axis.
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Display the parameters in a Grid

You can also display the data in a grid from the Calculate... menu (select Calculate->Reverb Times (RT-60)... or the [image: image25.bmp] button. It will only display for one measurement at a time and look like below.
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Click the [image: image27.png]Copy




 button if you want to copy the data to the clipboard and paste it to a spreadsheet (for example MS Excel). You can also select an area in the grid and click [image: image28.png]Copy




 to copy only the data you have selected. T30 for the bands 1000-2000 Hz is marked in the figure above.
In this case three reverberation times are plotted, EDT, T20 and T30. EDT is the early decay range (evaluated using the range 0 to –10 dB on the decay curve) and should correlate well with the subjective impression of the reverberation.

If the edr number is better than 35, the T30 gives the decay time according the definition (starting point –5, decaying to –35). It is possible to specify this in more detail from Room Acoustics->User Defined->Settings....

The corr number should be as near –1 as possible, if it deviates from this it indicates that the reverberation curve is not a straigh decaying line. This can be the case if a room is coupled consisting of two rooms. If this is the case, you may select the Schroeder Curve plot type and from this see if it is possible to do the reverberation calculation in two parts. For example, the first in the range –5 to –23 dB and the second from -23 dB to –45 dB.

More about measuring

If you are not going to use WinMLS for performing the measurements, you can skip this part.

Important! To get the best results, three things are important

1. Use sine sweep as excitation signal (will be in sections explained below)

2. Use as long measurement duration as possible. 

3. Make sure you have as high volume as possible from the loudspeaker. If you are using a sine sweep as excitation signal, be careful so you don’t burn up the loudspeaker. If you are using MLS-noise as excitation signal, a too high level on the loudspeaker should be avoided. Expiriement with different levels to see what gives the best result.

2 channel measurement

In order to do this you need to load a different setup. More info will be added later.

Theory: Impulse response

The impulse response is the basis for computing reverberation time and the other room acoustical parameters. To say it easy, the impulse response is the signal you get from a very short pulse, e.g. when you clap your hands. In a room, the sound will be reflected from the walls, floor and ceiling. The impulse response consists of the reflections that reaches the microphone.

Add picture from Peters article?

Theory: Measure impulse response using loudspeaker

A better result is usually given if the impulse response is measured using a stationary signal played from a loudspeaker instead of a short pulse. To obtain the impulse response from a stationary signal we use deconvolution. 

Also using a stationary signal gives a more accurate and repeatable result than using a short pulse. 

Bilde fra italiener artikkel om deconvolution?

Measure using loudspeaker

Go to Measurement->Settings... to display the dialog box shown in the figure.
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Under point 1. Max decay time + system delay, type the estimated maximum approximate reverberation time, if you click on the list, you get some alternative
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It is also possible to type in another value that those.

. Click on the 1. button to display help for more explanation.

Under point 2., note that the measurement quality usually improves with increasing the measurement duration. But it may be more demanding for the PC (especially if single sweep is selected as will be discussed later).

Setting sampling frequency and sweep range

The sampling frequency and sweep range is set in the bottom in the figure below. You should set the sweep range somewhat larger than the frequency range you are interested in measuring.
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Alternative 1: Measure using single sine sweep

Single sweep is set as default as shown under point 3. in the figure because it usually gives the best results. 
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Single sweep is robust against harmonic distortion, which means that you can use a high output volume on your loudspeaker. 

Single sweep is also robust against time variance, which means that you can get good results even if people are walking around in the room during the measurement. Read more about the other measurement methods by clicking the Help button in Measurement->Settings....

The disadvantage with this method is that it can be time-consuming to calculate the impulse response.

Note that some sound cards only will work if 
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is selected in Measurement->Settings.... If you have a VXpocket, it will work to set it to Internal as shown below.

[image: image35.png]8 Reference: [inemal =
e




Alternative 2: Measure using multiple sweeps

In a situation where you have very high background noise but no time variance you can select [image: image36.png]Multiple sweeps



 as shown in the figure below instead of single sweep. A multiple sweep is less computational demanding. 
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Alternative 2: Measure using MLS

This is a noise-like signal and can be used if the distinct sound of the sine sweep is not desired. (add reference)
Using music as excitation signal

This possible, but is not recommended for high quality measurements. (add reference)
1

_1076758940.doc


Recorded signal







Microphone 



as Input







Playback signal







Right   Left



 Output







Left    Right



   Input







Sound Card











Loadspeaker 



as Output












