Morset Sound Development




>   General  
>   User Tips  
>   RoomAcoustics  
>   ElectroAcoustics  
>   MusicalAcoustics  
>   Bugs&Improvements  
>   WinFlag forum  

Site Overview


Contact Us

Morset Sound Development  
+47 73915000  
Bellvegen 59  
7580 Trondheim, Norway  


WinMLS 2000 Forum

This forum has been retired and will no longer be monitored.
You can find our new forum at

Subject My answer

Date Fri Sep 20 2002 23:18
Author Lars Morset (

File: RME_LoopbackProblem.jpg

> enclosed you will find several wmb files related to my
> tests of teday.

Dear Boris, thanks for the nice quality measurements! The problem is the shifting of the impulse response. I'll try to help you.

>My setup : Looped Soundcard (both channels), 44.1 kHz
>Mode "Only if synched" and "Detect start" will give
>31, 41 and 50 samples delay (using 13,14 and 15 bit MLS
>signals). These values are too low.

WinMLS detects the start of the impulse response. If you increase the length of the measurement time (by using a higher MLS order) the noise floor is lower and the detection will be better which means that you will detect a longer delay.

>Mode "Loopback with/without endcheck" will give :
>a) 13 bit MLS : IR at 0 and 8190 samples (wrap around ?)
>b) 14 bit MLS : IR at 0 and 16382 samples alternating with
>an IR at 14337 samples (changes every other measurement !)
>c) 15 bit MLS : IR at 0 and 32766 samples alternating with
>an IR at 30721 samples (changes every other measurement !)

This is very strange. I found one error, see the attached picture. The file "Loop_endcheck_14337.wmb" has a much higher noise floor than "Loop_endcheck_16382.wmb", this is probably caused by the 2048 samples time shift. Did you use the mode "Use loopback with end-check" in Sound Card Settings? If yes, then WinMLS should give you an error message since there has been a gap in the measurement. But it will NOT detect the gap if it is exactly the same in record as in playback. Do you understand? Can this be the reason?

> Mode "Soundcard is synched, offset=0" will give 126 samples
> stable delay (realistic value).

Zoom in on the first 200 samples of the impulse response and set the vertical axis to "dB". Then you will see that the first 70 samples is only noise. If you have set the offset to "0", I would set it to "-70" to get rid of the noise in the beginning. This is of course not important for most types of measurements, also if you use the "Measurement System Correction" feature this will be corrected for.

This "sound card" works different than all the sound cards we have tested, all the other cards need an offset of 20-150 samples. Is this result always stable?

> So this should be a good platform for working, BUT :
> When I change mode from "Loopback" to "Synched" after
> having the IR at 0+16382, the "Synched" mode gives false
> results, i.e. IR at 14459 samples.

So it is not stable?

> If I tell you that the buffer size of the RME card is set
> to 2048, you may start interesting computations.
> The effect is : I think that I know how to avoid the
> problems,

Please let us know how. Do you mean setting the "Include initial time delay in meas." mode to "Yes, my sound card is synched" and setting the "Sound Card Delay [Samples]" to 0?

> but there seems to be a problem somewhere in the
> driver communication between WinMLS and RME.

I agree, if you know the RME guys I would appreciate if you could contact them about this.

I hope the answer was of some help.


reply show all Previous Next

Click here for this discussion's index

Morset Sound Development

Sign In